Get listed in the Spick and Span Directory

Carpet Cleaning Issues - Carpet construction, upholstery cleaning, stain removal, equipment, events, etc.

Problems with a steameasy 400

Posted by williamx (williamx), 14 March 2004
I've got a Prochem Steameasy 400 and the problem I suffer, is every time you run out of water you have to disconnect the solution pipe from the machine and insert a bar to blead the system, this also happen if you carry the machine on its side.

I had the same problem with my other Prochem steameasy 400.

Is it a design fault?  I also had a hydromist which is the same machine but different colour and never had this happen.

Can anyone help. Smiley Smiley

Posted by MB (Mark Betts), 14 March 2004
Why dont you just put an open connector on the end of the solution hose and bleed it back into the sdolution tank.


Posted by williamx (williamx), 14 March 2004
I've tried that and it didn't work, it only works by pressing the solution valve in on the machine Sad
Posted by Dynafoam (Dynafoam), 14 March 2004

It is a water pump, not an air pump - so it needs priming.

Posted by williamx (williamx), 15 March 2004
If thats the case why does it work ok when I put the water pump into a hydromist Huh
Posted by Ken_Wainwright (Ken Wainwright), 15 March 2004
Hi William

The solution's easy, don't run out of water!

However, presuming that you have a self priming Flojet or Shureflo, then it probably needs a service, or it may be possible that you have a poorly routed internal hose, perhaps it may even have a kink in it.

Safe and happy cleaningSmiley
Posted by Kinver_Clean (Kinver_Clean), 15 March 2004
Check that all your pipes and filters are clear this can affect the priming.

Also look to see if the pump inlet and outlet are above one another rather than side by side. If the outlet is below the inlet sometimes the pump has a problem clearing the air. If this may be the case turn the pump or the pump head over.

Just a thought....


Posted by williamx (williamx), 16 March 2004
Thanks Trevor
I've just striped and cleaned everything on the machine but alas the machine won't co operate and it refuses to work until I bleed it Cry
Posted by bruce_wiles (Bruce Wiles), 16 March 2004

I also have a Steameasy 400 and I have to bleed mine too - talking to a tech he said most 400's suffer the same problem. Yes I think it is a design issue.

Posted by williamx (williamx), 17 March 2004
Thanks Bruce

I thought it was a design fault maybe Prochem know about this problem and will soon come up with an answer to fix it Huh
Posted by Dave_Parry (Dave Parry), 17 March 2004
Maybe, Call me pessamistic Maybe not
Posted by Dynafoam (Dynafoam), 17 March 2004

You could call it a design fault, in that the ideal design would have, at the highest level, the tank, then the inlet of the pump, the outlet of the pump and at the lowest level, the output connector.

Practicalities dictate that this does not occur.

The solution offered by Mark should work, as most definately will the innitial solution offered by Ken.

Posted by williamx (williamx), 18 March 2004
I've solved the problem.  I've just brought another machine Grin Grin Grin

This page is a thread posted to the cleanitup forum at and archived here for reference. To jump to the archive index please follow this link.